Fix for some with the Dump-to-Desktop bug

Discussion in 'The Battlefield 1942 Resource' started by Unregistered, Apr 21, 2003.

  1. Unregistered Guest

    Ok guys, this solved my problem where I clicked on the shortcut to launch the game, the game screen would come up for a couple seconds, then I would get dumped back to the desktop.

    Go to C:\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings

    edit the VideoDefault.con file in there using Wordpad or Notepad.

    Here's the important line:

    renderer.allowAllRefreshRates 0

    change this line to read

    renderer.allowAllRefreshRates 1

    Save the file, re-start the game....voila! Should work.

    My guess is that with the value set to 0, it didn't like the fact that the vertical refresh rate of my system was set to 85hz. So, by changing the value to 1, it would accept any refresh rate.

    Enjoy!
  2. Unregistered Guest

    I dont have a "mods" folder...but I do have a

    C:\Program Files\EA GAMES\Battlefield 1942\Settings folder...

    and in there is videodefault.con but the renderer.allowAllRefreshRates line of text was not in there... tryed adding it and making it 1 and it still didn't work



    Report this post
  3. Unregistered Guest

    thanks, my game works now. you alone have already proved more helpful than EA's technical support and their online help file combined.
  4. Unregistered Guest

    I'm glad my fix helped some of you. I see that some of you don't have the line in the VideoDefault.con file regarding the refresh rate. The only thing I can think of is that you don't have the "Road to Rome" expansion pack, or maybe not even the 1.31 patch.

    All I know is that I bought the original game and the R2R expansion pack the same day, installed both, then downloaded the 1.31 patch and installed that.

    It was then that I started my debugging process to try to resolve my problem. So if you don't have the R2R pack and the 1.31 patch, I suggest you add get them first before trying my fix.

    Btw, after I came up with my fix, I discovered a really awesome BF1942 tweaking guide, that includes the fix I found. I wish I had read this before I even installed the game. Anyway, here it is:

    http://www.tweaktown.com/document.php?dType=guide&dId=420
  5. Unregistered Guest

    Hi all,

    I may have figured out everyone's problems (hopefully).
    NOTE: I'm only using the Demo.
    Here's what i did.

    1) installed the new NVIDIA driver (not from your video card manufacturer)
    http://www.nvidia.com/content/drivers/drivers.asp

    I also did this (but i suspect had no effect)
    1) installed VIA 4-in-1 driver (chipset update for motherboard)
    2) installed DirectX 9.0a
    3) installed Demo patch.

    Not only did the game run....but i was also able to crank up the video details far above what they were before.


    I'm running in Win2000.
    AMD 1Gig
    AOPEN PA256 Geforce2 MX
  6. Unregistered Guest

    dumping to desk

    One reason the game will dump to desk when loading the game is if there is nothing to load. Maybe you are using the wrong disk, try using the first disk but let the autorun program take off from the disk and then hit play. It could be this simple!!!!
  7. Unregistered Guest

    Many thanks

    Just dropping in to confirm this refresh fix worked for me and likely will for many others. Many thanks to you.
  8. Unregistered Guest

    hi, i treied thhat and it still dosent work.... my refreshrate is 100.
  9. Unregistered Guest

    i got the "fix" off ea's tech support (i also downloaded 1.31 patch) and it still doesn't work

    nvidia geforce4 440mx 64mb ddr
    (most recent driver installed)

    if you have some other way of fixing this annoyance, please email me at crihsagnlel@mail.com, or crihsagnlel on aim/yahoo.
  10. Unregistered Guest

    I tried the patch and all the new drivers and still couln'd get it to work. I downloaded and installed DirectX9 and it worked like a charm for me. It even got a couple of other games running that I have had problems with.
  11. Unregistered Guest

    Tried all of these things and still no luck. If i don't [atch the game it's fine. As soon as i try to patch it it dies. Tries to start...black screen..drops to desktop. WHen i try to launch it from the cd. IT then comes back and tells me to eject and reinsert the cd and try again. WHich ofcoarse I do. Again it fails. So I change Cd drives as have three in my case.....still no luck. One last try i have another cd drive lying around so i try that one..................F**K still no luck. Help any body this is the error i get when i try to start it from the shortcut on mydesktop
    Version BF1942 (Ver:26087/2002-08-30, 10:43)
    Log created 2003/06/16:18.02d
    --------------------------

    SystemInfo:
    -----------

    Cpu:
    Running on AMD Athlon(TM) XP 2600+ at 2033 MHz
    Supports AMD 3DNow
    Supports MMX

    Renderer:
    Number of adapters:1
    Adapter:0
    Driver:nv4_disp.dll
    Description:ASUS V7700 Ti SDRAM v43.45D
    Product:6 Build:4345
    DriverVersion:14:1
    VendorId:4318 DeviceId:337 Revision:164
    FullScreen Mode
    24:8 bit depth buffer
    supports pure d3d device. validVersion:0 getSupportedMaxVertexShaderConstants():0 m_d3dCaps->mMinVertexShaderConstants:96
    D3D Present parameters
    m_d3dpp.BackBufferWidth 800
    m_d3dpp.BackBufferHeight 600
    m_d3dpp.BackBufferFormat 22
    m_d3dpp.BackBufferCount 1
    m_d3dpp.SwapEffect 1
    m_d3dpp.hDeviceWindow 002D01A8
    m_d3dpp.Windowed 0
    m_d3dpp.EnableAutoDepthStencil 1
    m_d3dpp.AutoDepthStencilFormat 75
    m_d3dpp.Flags 0
    m_d3dpp.FullScreen_RefreshRateInHz 60
    m_d3dpp.FullScreen_PresentationInterval 2147483648
    Debug asertion failed!

    Module:
    File:
    Line: 0

    Text: warning :Shaders/Sprite vertex shader not created

    ANY HELP IS APPRECIATED
    Signed going insane
  12. Unregistered Guest

    Hey i have the same problem but I dont get the error i try to start the game get the first splash screen and goes black get an error beep and I sit at the desktop, ???? what can i do?
  13. Unregistered Guest

    Just wanted to let you all know that I had the same exact problem as many people have had with this game. The game would just randomly crash to the desktop whether being in the game or at the loading screen. I tried everything, two straight weeks of nothing but troubleshooting. I am running a Pentium 4 2 Ghz. processor with 512mb ram, a NVIDIA GeForce 2 video card, and a SoundBlaster Live sound card. Why the hell this game won't behave properly had become beyond my scope. Well, I decided hell, i'm tyring a different video card (which I was skeptical about, being I've read some postings in here saying that changing the video card didn't help them)....well, I tried slappin in my roommates GeForce 4 and walllahhhhhhhh, PRESTO, ITS MAGIC, ITS WORKING ONCE AND FOR ALL!!!!!! No problems what so ever, seems as if my video card may be damaged!! Yours could be too!!!!!

    Jason
  14. Unregistered Guest

    I have the same problem where I applied the nvidia refresh rate fix and set my rez to 1182 x 864 @ 100mhz . I changed the variable in

    VideoDefault.con to renderer.allowAllRefreshRates 1

    and the game still crashes as soon as I see the BF1942 screen. I have installed the game from the orgional CD I bought some time ago and I applied the BF1942 1.4 patch.

    Specs:

    p4 2.53

    1 gig DDR ram pc3200

    GF FX5900

    WinXP Pro + Service Pack 1
  15. Unregistered Guest

    I posted the above post. I got it to work perfectly by uninstalling the nvidia refresh rate fix and setting my rez @ 60

    I would love to be able to use the fix and have my settings @ 100mhz because CS looks so much better like that. Please help if you know anything I could try.
  16. Unregistered Guest

    ???

    how do i edit the file anyways?????
  17. Unregistered Guest

    i had a problem when i would start the game it would load the map and the second the game started it woyld dump me back to desktop. this was a direct result of my via 4 in 1 driver.
    i updated it and have ben 100% cool ever sence!
  18. Unregistered Guest

    fix

    Make sure VIA 4in1 drivers are installed. Will correct problem all updates. :)
  19. Duster Guest

    possible solution to dumping

    I was having the same problem with dumping to the desktop when the game was just starting up. A friend had been messing with my monitor's driver and other things to get DOD to work for me. In the process, 1942 started doing the dumping where it had been working fine before. I thought it HAD to be something related to changing to XP which we had also recently done. My son has a system exactly like mine except we had to replace his monitor. 1942 worked just fine on his. We moved his monitor to my computer and the game stopped dumping because we changed the driver to the default driver and it worked. I don't know if all this makes sense to you...I have a basic idea on most stuff but this is about stretching my limit. Let me know if you need more info.
  20. Unregistered Guest

    Via driver updates worked for me :D

Share This Page