Problems with sound when zoom out camera

Discussion in 'Starcraft 2 (SC2) Editor Help' started by MissKerrigan, Mar 30, 2012.

  1. MissKerrigan Active Member

    Hello,

    I did it! I zoomed out the camera at the start of the game!

    But now I got the next issue: can't hear any sound effects of my units when they fire
    Does anybody knows what's going on here?

    MissKerrigan
  2. Dave312 Censored for your safe viewing

    Those sound effects are considered 3D sounds, meaning that the further your camera is away from the source of the sound, the lower the volume of the sound is when it is played. There may be a way to adjust the factor that is used to calculate how much the volume is reduced by per unit of distance the camera is away from the source, but I don't know off the top of my head.
    1 people like this.
  3. MissKerrigan Active Member

    Well I did the next thing: I zoomed the camera out a little so you still hear the sound but the problem is when you scroll your mouse wheel forwards, you can't zoom out again
    And if I create a lock camera trigger, you can't scroll the screen to left/right/top/bottom

    I can create a zoom out trigger for seeing the maximum map + a lock camera trigger so players can't scroll their wheel but then I got this sound issue like I told above here :<> /
  4. Dave312 Censored for your safe viewing

    Open up the Cameras data type, and select the Default Camera object. Edit the Zoom Levels + property, select the first index, and change the Distance parameter to something larger. This will make it so you can zoom out further with the mouse scroll

Share This Page