Very odd issue installing MySQL server

Discussion in 'General Technical Support' started by C-Death, Mar 28, 2012.

  1. C-Death

    C-Death I love you

    Hello everyone.
    When I install mySql server, everything goes just fine, except for it always tells me I have the wrong password.

    Basically, the installation goes fine, but when it runs the configuration wizard at the end, it always returns ERROR 1045: Access denied for user 'root'@'localhost' (using password: YES)

    Now, what is really odd is that I haven't set a password for it. I've searched for hours on google in hopes of finding a solution, but everything I've tried simply does not work. Anyone have any suggestions?
    Also, I've uninstalled probably 10 times.

    Thanks.
  2. UndeadDragon

    UndeadDragon Super Moderator Staff Member

    It may be the fact of "using password: YES". Try to connect just using root@localhost with no password at all.
  3. C-Death

    C-Death I love you

    This too I have tried, I've tried getting in to the command line, and even it demands a password
  4. UndeadDragon

    UndeadDragon Super Moderator Staff Member

    What are you using to connect to it? What command, or script are you using (PHP, or command line)?
    • Like Like x 1
  5. C-Death

    C-Death I love you

    I'm sorry, I don't quite follow you. Mysql installs just fine, it seems, and then goes to the configuration wizard. Once there, I accept the default settings until I get to the end, which is where it asks me for a password. I enter the password I want (and I do NOT click enable access from remote, if that means anything) and then it goes through setting up. It goes just fine until it gets to "Applying security settings". Then a nasty red error box pops up telling me that it was unable to configure because of a password error for the user ROOT@localhost
  6. C-Death

    C-Death I love you

    I got it to work!

    What I did (for anyone else who may be having similar issues)
    You can't just uninstall, you have to go through to the paths and delete the mysql folders, and also delete the registry keys.
  7. UndeadDragon

    UndeadDragon Super Moderator Staff Member

    So, a full uninstall and re-install fixed all the problems?
  8. C-Death

    C-Death I love you

    Indeed.

Share This Page