System ArrowKey

Bribe

vJass errors are legion
Reaction score
67
It would be:

JASS:
method onKeyEvent integer key, boolean press returns nothing
    call MoveHero(hero[this])
endmethod


Really short API. I am not going to add the same parameter twice.
 

tooltiperror

Super Moderator
Reaction score
231
I was very eager to review this system, and I was waiting to get all my work done before reviewing it. As per Bribe's request, let's get going.

1. The code commentation is superb. Just really superb. Most functions are described, important blots have headers describing them, the code has sections marked off, and you got everything good. This is a script I'll be referring to people when it comes to commenting on code. Really well done. The documentation, on the other hand, I will address below.

2. [LJASS]ALL_FEATURES[/LJASS] is a really good implementation detail, and it is excellent that you included it. From my C++ influence I would prefer a function such as [LJASS]ArrowKeyActivateAllFeatures()[/LJASS] or something of the like, but from a developmental stand point, you should know all the functions you are using before you use them. However, this means that systems and scripts requiring ArrowKey must point out that [LJASS]ALL_FEATURES[/LJASS] should be [LJASS]true[/LJASS].

3. "[ljass]private module M[/ljass]" should have a comment explaining why it is a module (vJASS initialization order).

4. When we get to the constants, this is where I get a little more upset with your coding style. [LJASS]ArrowKey.LEFT[/ljass] looks absolutely hideous. Most languages with object oriented features use symbols or functions to get around this ugly stuff, so you should change them to regular global constants, probably [LJASS]ARROW_KEY_LEFT[/LJASS]. Remember that, while OOP is nice, Jass is a multiparadigm language.

5. At [ljass]ArrowKey.registerEvent[/LJASS] you do not note that you need to take the arguments. Awful commenting mistake.

6. Again, all your debug functions show how your coding triumphs the other recent prominent Jassers. Also, the section headers are another good addition to your code, and shows how structured it is.

7. At "[ljass]implement M[/ljass]" you should note that it is the initialization module.

8. It would be wiser to rename "onKeyEvent" to "onArrowKeyEvent" to as not conflict with something like, say, any key being pressed. Despite Warcraft III having a limitation to not detect all keypresses, it is probably philosophically wrong.

9. I really don't see why this style of documentation is becoming more popular. Also, a mistake, on the .LEFT and .RIGHT and so on constants, you didn't mention they were static. You also don't describe what the axes are, or what a negative value is for a key. Here, Earth-Fury beats you by so much, his documentation is far superior.

One last note: Where are the imperative style wrappers?
 

Sgqvur

FullOfUltimateTruthsAndEt ernalPrinciples, i.e shi
Reaction score
62
tooltiperror:
1. ArrowKey.LEFT looks absolutely hideous.

2. Most languages with object oriented features use symbols or functions to get around this ugly stuff, so you should change them to regular global constants, probably ARROW_KEY_LEFT.

3. Remember that, while OOP is nice, Jass is a multiparadigm language.

1. "From my Jass2 influence" I do prefer/like more ARROW _KEY_LEFT than ArrowKey.LEFT (but ArrowKey.LEFT is not really that bad because it could be way worse -> c_keyLeft).

2. What languages are you writing about? Can you elaborate more on "symbols or functions to get around". I am 99% sure no OOP guy thinks ArrowKey.LEFT is "ugly stuff".

3. Which paradigms are you writing about again? Cause it seams to me Jass2 is pretty much imperative all the way.
 

tooltiperror

Super Moderator
Reaction score
231
I am not responding to your post unless you use typical forum post writing conventions. This "1. 2. 3." business is nonsense. You can use "greentexting" (the > character) or [NOPARSE]
[/NOPARSE] to write a reply as much of the rest of the forum does.

Good day to you sir.
 

Sgqvur

FullOfUltimateTruthsAndEt ernalPrinciples, i.e shi
Reaction score
62
tooltiperror:

1. This "1. 2. 3." business is nonsense.

2. I am not responding to your post unless you use typical forum post writing conventions.

1. And you think it's nonsense because?
The reason I use 1 -> 1, 2 -> 2, ..., n -> n statement matchup is because I think it's the second best thing after a table (I don't think/know if tables can be made in this editor). It's pretty clear which statement of the author is being addressed, and replying to multiple people in a single post is not a problem.

2. It's your choice to respond/reply to my post, but ignoring it because of the "style" of expression is kinda childish.
 

Bribe

vJass errors are legion
Reaction score
67
Updates thanks to tooltiperrors's advice:

- Heavily invested in the documentation.
- Re-added function wrappers.
- Split the library into two instead of the static if: ArrowKeyEvent and ArrowKey.
 

tooltiperror

Super Moderator
Reaction score
231
That's some creative use of textmacros :p

Approved. This is now my arrow key library of choice.
 
General chit-chat
Help Users
  • No one is chatting at the moment.

      The Helper Discord

      Members online

      No members online now.

      Affiliates

      Hive Workshop NUON Dome World Editor Tutorials

      Network Sponsors

      Apex Steel Pipe - Buys and sells Steel Pipe.
      Top