Battlefield connection problem after 1-3 min*??

U

ulriksandholt

Guest
I can play all other online games without any problems, but this one works fine for about 2 min and then it says connection problem and disconnects

I have XP, amd 1800+, 756Mb ram, geforce3Ti500......so its not a hardware insufficiency problem.

Have any of u guys here had the same problem....and do you have a fix......

Yesterday i played 1 server without any problems......strange for 1½hours....the other servers disconnects me.

I have an adsl 256k connection and only choose servers with ping<250

Please help me
ulrik
 
S

Swilo

Guest
Same thing happens to me on any server, regardless of ping or number of people playing.

AMD Tbird 1.4GHz
512MB DDR (2x256)
Asus A7M266 (AMD 761 north, VIA 686b south, does not have latest BIOS version nor VIA 4in1 because I've never needed either)
ATi Radeon 32MB SDR (latest drivers)
SBLive x-Gamer (not 5.1, latest drivers)
Maxtor 40gig master, WD 120gig slave
3Com NIC (905C-TX or something)
Connected through a DLink DI-704P router/firewall into a Westell DSL modem with Verizon 768/128 service

Everything else with the internet works fine. What port does the game use? Maybe I could try opening it in my firewall.
I suggest you check XP's built-in firewall.
 
L

LT.Homer Simpson

Guest
It may also be a possiblity that you may be behind an isp NAT.
Some ports in NATs have difficulity tranmitting udp packets.
 

Wargasm

Administrator
Staff member
i noticed on some servers your ping is great . some ppl join and u start to lag like a mofo .
i got the feeling these are not dedicated servers .
 
E

endlessmadness

Guest
same problem here..

1.8GHz P4 XP
256 MB 'RAM'
40 GB hard drive
nvidia GF4 Ti 4400
dsl (through router)

sometimes i can manage to stay one for longer, others i get dropped right after a few minutes, no matter how many people are playing. it is starting to really bug. it might not be so bad if the game didn't take so long to load wake island map every time i tryand reconnect. give me a patch, or give me death.. this game is that good ;)
 
U

ulriksandholt

Guest
Then it works then it does not

Just before i could stay on all the servers i connected to......but now i cant anymore......grrrrrrrrrrrrrrrrrrrrrr.......i tried to disable my xp firewall and thought it worked....but i didnt...
HEEEEEEEEEELP!!! i need to play....must have fix......UGH!
ulrik
 
M

Master

Guest
After doing alot of reading on this, i'm pretty sure this isn't a netcode problem but an admin problem. People setting up servers are heavily overpopulating their servers. People with cable/dsl should only be hosting up to 12 players, max. Anything more than that will not enable the server to be able to send all the information to the clients that it needs to.

It also seems that listen servers (non-dedicated) have VERY bad lag problems. I haven't seen a way to filter these out in the ingame server browser, so it isn't very easy to recognize which servers are dedicated and which aren't. Lets just pray EA releases the server lists so we can use our beloved ASE to browse servers.
 

Wargasm

Administrator
Staff member
Why EA used gayspy is beyond me ..
it show servers totally empty and they are full to the hill
some servers i cannot even connect the game crashes
 
G

Guest

Guest
lol ive been trying to play this game for 3 days off and on.... only once did i manage to have a good time playing. now all i get is that awful connection problem message. this has to be fixed and soon......im ready to give up, but i cant.... lol this game rocks
 
E

endlessmadness

Guest
yeah..

well as sucky as this crappy connection problem is at least we aren't alone... lol. it feels like AA in here, we are addicted to a game we can't play! it is disrupting our lives ;-)
 

Wargasm

Administrator
Staff member
ok this is what i do nowdays
soon the servers show up
i scroll down asap all the way
check out quickly for a server with a decent ping and some players ..
no probs allday
 
E

endlessmadness

Guest
ok, i went down to best buy and bought 256 megs of DDR ram and now the game loads a lot faster and plays much better. i also tried that server trick wargasm suggested and it worked for a bit longer, but still got disconnected before 15 mins. good luck.. and BUY RAM you won't regret it
 
U

ulriksandholt

Guest
Ram sure helps performance

But the connection problem remains......i guess it must be beginners trouble for the game dev team.....theyll probably fix it in a patch.

I have 756Mb of DDr ram and my game is running fluiently....whenever the ping is alright:)
But thnx for posting guys....

its nice that people care to write....

Tnx from Denmark
 
G

Guest

Guest
i agree with you about the patch fixing this bug. anyway, i look forward to seeing you on the battlefield in the near future.. hopefully on the same team :) and if i ever work this problem out i will be sure to post the solution here! please do the same, thanks. it is just a matter of time i think.

best wishes,
david
 
E

endlessmadness

Guest
hey how may of the people having connection problems are going through routers?? and if so what kind??

i updgraded my firmware and that seemed to really help with the amount of time i am able to stay connected. i have a linksys BEFSR41 and changed my firmware to 1.41 and stayed on today for a record breaking 45 mins straight. :-D
 

Wargasm

Administrator
Staff member
the dev team allready mentioned soon the game is in the stores they will have a patch rdy :)
prolly not for the demo tho
right i am off to modify ASE totally sick of depending on gamespy and their crap filters
 
G

Guest

Guest
Solution!!!!!

In your BF1942 directory open the MultiplayerServers folder.
Rename GameSpyJoin_MP_Demo.dll by changing the extension to .bak
Make a copy of GameSpyLanJoin_MP_Demo.dll
Rename this copy to GameSpyJoin_MP_Demo.dll
The in-game browser should no longer function, so the lag should hopefully disappear.
 
P

Passerby

Guest
Problems staying connected?

I was having the same problem staying connected w/ bf1942 servers. I have a D-Link 604 and upgraded the firmware. After that, I've had no problems. I recommend to anyone having issues to make sure you upgrade your firmware, hopefully it will be all you need to get back to some good ol' battlefield

---------------------------------------------------------------------
check it...
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • Ghan Ghan:
    We did!
  • Ghan Ghan:
    The old shoutbox wasn't supported anymore. We updated xenForo, so it had to be replaced.
  • jonas jonas:
    let's see if everyone finds it... the nice thing about the shoutbox was I could check on it even while logged out, but the existence of this one is hidden when you're not logged in
  • Ghan Ghan:
    We can fix that.
  • Ghan Ghan:
    Chat should show on the sidebar when not logged in now.
  • Ghan Ghan:
    (You'll still need to log in to post messages)
  • Ghan Ghan:
    Test!
  • tom_mai78101 tom_mai78101:
    I must be in a test server.
  • tom_mai78101 tom_mai78101:
    Nice, Twitter tweets embedding now works
  • Wizard Wizard:
    Yup.
  • Ghan Ghan:
    Excellent.
  • Ghan Ghan:
    @tom_mai78101 Hello there.
  • Ghan Ghan:
    Tagging works in the chat too.
  • tom_mai78101 tom_mai78101:
    @Ghan Missed it.
  • Wizard Wizard:
    Still fixing things here and there. Added widgets to the portal, will make it match the ones here on the forum index tomorrow.
  • Ghan Ghan:
    The venerable World Editor Tutorials site has been converted to HTTPS at last.
  • jonas jonas:
    cool
  • jonas jonas:
    and I can even edit my messages, nice
  • seph ir oth seph ir oth:
    GENERAL CHIT CHAT, YOU ARE A BOLD ONE
  • Ghan Ghan:
    Hello there
  • The Helper The Helper:
    this new chatbox is great and the forum software update is great too
    +1
  • The Helper The Helper:
    upgrade has fixed forum registration spam problem
  • tom_mai78101 tom_mai78101:
    Something tells me we might be able to customize the chatbox a bit, considering that there's a gap under every message.
  • Wizard Wizard:
    Going to deploy a fix soon, just had to take some time for myself this weekend.

    Members online

    No members online now.

    Affiliates

    Hive Workshop
    Top