Battlefield Help! The buildings, tanks etc. are all white and gray!

M

maveric

Guest
Everything except the landscape (and sometimes the guns) in the game is corruped somehow, where everything is gray and white.

I'm always updated with the latest drivers and patches.

I believe the demo version looked fine when I played it before the full version.

What is wrong? What can I do?

I have attached an image file from within the game to this post.
 

Attachments

U

Unregistered

Guest
hey i have almost the same problem except mine is black and blue .
 
M

maveric

Guest
PIII 733mhz, 256mb RAM, Gainward GeForce4 MX440 64mb, Win ME, DirectX 9.0 a, the latest drivers for the graphics card, 1.3GB available diskspace for the game. Motherboard: Matsonic 7117c.

Anything else you want to know?
 

Wargasm

Administrator
Staff member
is that a via chipset for the mobo >?
might wanna use the latest hyperion drivers
 
M

maveric

Guest
Yes, it's a Via chipset and I already have the latest hyperion drivers.

I don't know, but I might be missing a certain folder in the Battlefield-folder.

Is there suppose to be a folder called "Xpack" or something somewhere? I don't have that anyway.
 

Wargasm

Administrator
Staff member
seems tobe an open GL problem
try to restore the default vidcard settings

dunno if it works but that is the best i can think off .

what kinda resolution do u play the game in ?
looks like 1024*768
 
M

maveric

Guest
I Don´t have a problem when running the demo version of the game though :-/

I have used the default videocard settings, but that dosen't work either.

I don't remember what kind of resolution I was using when I took that screen dump, but I have tried different resolutions.

I have no problems though when running other games like Return to Castle Wolfenstein.

Could I be missing some graphic-related file/s in the game?
 

Wargasm

Administrator
Staff member
i noticed that certain dvd players can corrupt the game during installing the game .

might try to install from a different medium then the normal dvd or cd player
 
U

Unregistered

Guest
solve white / dark screen problem

There is a conflict between your graphics card and your onboard integrated graphics on your motherboard.
Go into your BIOS and disable your onboard integrated graphics.
This also can be done through device manager.
 

Wargasm

Administrator
Staff member
thanks
forgot about that , cause i assume everyone has disabled their onboard vidcard hehe
 
M

maveric

Guest
I am out of town right now, so I haven't been able to test your recomendations. But as soon as I get home (probably in a week) I will test them.


Wargasm:

You could be right about the DVD-problem, because I did install the game (at least one of the two discs) with my DVD-player.
So I'm gonna try to reinstall the game by only using my ordinary CD-player this time.


When it comes to the onboard integrated graphics, I don't know if I have that. And since I'm not able to use my computer right now, I'm unable to look at BIOS and Device maneger.

I did just now download the user manual for the motherboard but I could not really find any "onboard integrated graphics" written there. It just says that I do need a graphics card to be able to use the computer. However, I did find this written in the BIOS section of the manual:

"Video Default: EGA/VGA
This item defines the video mode of the system. This mainboard has a built-in VGA graphics system so you must leave this item at the default value."

Is this what you mean? So I'm able to disable this when I get home, and the game should be fine?
 
U

Unregistered

Guest
sorry .. but I`m not the one who found the solution .. I`m another Gust having the same problem ..

so please tell me .. where can I find the BIOS ..






MWZ
 
M

maveric

Guest
When you turn on your computer, your monitor should display something like "To enter BIOS, press the "Delete" button now".

So just do what it tells you to do...
 

Wargasm

Administrator
Staff member
well maveric it is simple to see if you got 2 places to connect your monitor cable you got an inbuild vidcard .

or they put a nice black plastic cap on it .
 
M

maveric

Guest
Well, I don't have another monitorport, other than the one on my graphics card, so I guess I dont have integrated graphics.

The built-in VGA graphics system i wrote about has got nothing to do with it then?
 
M

maveric

Guest
Alright. I will try the reinstallation without using the DVD then, and hope that it works.
 
U

Unregistered

Guest
still facing the same problem !!

I installed it without using the DVD player .. but every thing still in blue and dark !
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • Ghan Ghan:
    We did!
  • Ghan Ghan:
    The old shoutbox wasn't supported anymore. We updated xenForo, so it had to be replaced.
  • jonas jonas:
    let's see if everyone finds it... the nice thing about the shoutbox was I could check on it even while logged out, but the existence of this one is hidden when you're not logged in
  • Ghan Ghan:
    We can fix that.
  • Ghan Ghan:
    Chat should show on the sidebar when not logged in now.
  • Ghan Ghan:
    (You'll still need to log in to post messages)
  • Ghan Ghan:
    Test!
  • tom_mai78101 tom_mai78101:
    I must be in a test server.
  • tom_mai78101 tom_mai78101:
    Nice, Twitter tweets embedding now works
  • Wizard Wizard:
    Yup.
  • Ghan Ghan:
    Excellent.
  • Ghan Ghan:
    @tom_mai78101 Hello there.
  • Ghan Ghan:
    Tagging works in the chat too.
  • tom_mai78101 tom_mai78101:
    @Ghan Missed it.
  • Wizard Wizard:
    Still fixing things here and there. Added widgets to the portal, will make it match the ones here on the forum index tomorrow.
  • Ghan Ghan:
    The venerable World Editor Tutorials site has been converted to HTTPS at last.
  • jonas jonas:
    cool
  • jonas jonas:
    and I can even edit my messages, nice
  • seph ir oth seph ir oth:
    GENERAL CHIT CHAT, YOU ARE A BOLD ONE
  • Ghan Ghan:
    Hello there
  • The Helper The Helper:
    this new chatbox is great and the forum software update is great too
    +1
  • The Helper The Helper:
    upgrade has fixed forum registration spam problem
  • tom_mai78101 tom_mai78101:
    Something tells me we might be able to customize the chatbox a bit, considering that there's a gap under every message.
  • Wizard Wizard:
    Going to deploy a fix soon, just had to take some time for myself this weekend.

    Members online

    No members online now.

    Affiliates

    Hive Workshop
    Top