System Knockback System

emjlr3

Change can be a good thing
Reaction score
395
use setwidgetlife will not give bounty
 
Reaction score
456
Yes, I know. But if I use UnitDamageTarget(..), I'd need another argument for the damager.

I can change that of course.
 

Cohadar

master of fugue
Reaction score
209
You can use SetWidgetLife if you make sure that health does not go below 1.
So basically that way unit cannot die from bash but if it gets to 1 hp it will not live much long anyways :D
 
Reaction score
456
I cannot use UnitDamageTarget(..), because for some reason the target will never take damage. But if I try to damage the knocker instead, it works fine (but of course damages the knocker).

EDIT://It seems that I cannot damage the unit while it's paused.
 

emjlr3

Change can be a good thing
Reaction score
395
then don't pause it. adding an argument for control is another option, one most people may welcome

setunitx/y allows control, setunitposition does not, and at the interval, it is as if the unit is paused reguarldless
 
Reaction score
456
So basically, you're saying:
Use SetUnitPosition(..) instead of x and y? And if I do so, I have no reason to pause the unit?
 

hell_knight

Playing WoW
Reaction score
126
Yep , at a low interval every command issued would get intterupted already so its impossible for any order to occur.
 

Cohadar

master of fugue
Reaction score
209
So basically, you're saying:
Use SetUnitPosition(..) instead of x and y? And if I do so, I have no reason to pause the unit?

true true, but than again if this is going to be used for more than knockbacking people might want to have it as option as emjlr3 said.

And as I said there will always be people who want this and that added so they could do their stuff more easily.

And in the end you would end up having 10000 arguments in your system.
Just think what Eric Cartman would do in this situation....
 
Reaction score
456
I have mental problem here. It's about the function name.. :p

KnockbackUnit(..) sounds stupid.. Knockback(..) is boring.. UnitKnockbackTarget(..) is too long.. UnitKnockTarget(..) is weird?

What should I name the function? As it's going to have first two arguments named "whichUnit (knockbacker) and "target (knockbacked)".

EDIT: //No time to think, must ACT! Weird names FTW!
EDIT2://Updated!
 
General chit-chat
Help Users
  • No one is chatting at the moment.

      The Helper Discord

      Members online

      No members online now.

      Affiliates

      Hive Workshop NUON Dome World Editor Tutorials

      Network Sponsors

      Apex Steel Pipe - Buys and sells Steel Pipe.
      Top