Tool Leak Check v3

Discussion in 'Graveyard' started by Im_On_56k, Mar 3, 2008.

  1. Zedzy

    Zedzy ℑΣÐℑΨ

    Ratings:
    +41 / 0 / -0
    I don't know much about computers so can some1 help me with this:
    [​IMG]

    How do I get the most recent one or whatever?
     
  2. BRUTAL

    BRUTAL I'm working

    Ratings:
    +118 / 0 / -0
    the older version works fine for me,but the newer ones dosnt :(
    i have the same problem as zedzy, and i downloaded that file and placed it in my system32 w.e, but it still dont work :banghead:
     
  3. Julian5

    Julian5 Guest

    Ratings:
    +0 / 0 / -0
    There are a couple of issues.

    First off, on the unit group leaks, why doesn't it show "Custom script: set bj_wantDestroyGroup = true"?

    While not as efficent as setting a unit group variable then destroying it, it's alot easier.

    Also, it complains about not removing integers. o_O They don't leak, so it shouldn't say that, should it?

    Edit: Also, when I DO remove a point leak by setting it to a variable with something added like a polar offset, it goes emo and says I need another variable to fix that leak. o_O

    (Line: 6) (Word: 3) Location Leak
    Set loc = ((Center of Mountains Enter <gen>) offset by 100.00 towards 90.00 degrees)
    Set loc = ^Leak
    (Suggested Fix) Set MyLocation = ((Center of Mountains Enter <gen>)
    (Suggested Fix) Set loc = MyLocation offset by 100.00 towards 90.00 degrees)
    (Suggested Fix) Custom script: call RemoveLocation(udg_MyLocation)

    (Line: 6) (Word: 8) Location Leak
    Set loc = ((Center of Mountains Enter <gen>) offset by 100.00 towards 90.00 degrees)
    Set loc = ((Center of Mountains Enter <gen>) ^Leak
    (Suggested Fix) Set MyLocation = offset by 100.00 towards 90.00 degrees)
    (Suggested Fix) Set loc = ((Center of Mountains Enter <gen>) MyLocation degrees)
    (Suggested Fix) Custom script: call RemoveLocation(udg_MyLocation)
     
  4. Knight7770

    Knight7770 Hippopotomonstrosesquiped aliophobia

    Ratings:
    +187 / 0 / -0
    Because that is an horrible way of removing unit group leaks.
     
  5. Flare

    Flare Stops copies me! Staff Member

    Ratings:
    +662 / 0 / -0
    Not being as efficient may explain why it's not a very viable option for leak removal (from what I've heard, it doesn't even work sometimes :S) and you can't use the group later which is one more good point about using group variables
     
  6. PurgeandFire

    PurgeandFire zxcvmkgdfg

    Ratings:
    +513 / 0 / -0
    It is because it destroys it on ForGroup call. I don't see how it is inefficient though, I mean, the trigger still processes the if, it just doesn't perform the action.

    No it isn't horrible or nothing, it actually is accurate kind of because it does it at the instance (I think)...
    JASS:
    function ForGroupBJ takes group whichGroup, code callback returns nothing
        // If the user wants the group destroyed, remember that fact and clear
        // the flag, in case it is used again in the callback.
        local boolean wantDestroy = bj_wantDestroyGroup
        set bj_wantDestroyGroup = false
    
        call ForGroup(whichGroup, callback)
    
        // If the user wants the group destroyed, do so now.
        if (wantDestroy) then
            call DestroyGroup(whichGroup)
        endif
    endfunction
     
  7. Kazuga

    Kazuga Let the game begin...

    Ratings:
    +110 / 0 / -0
    Hm, I downloaded both zips but nothing hapends when I run the files, neither one of them.. Do you need any other program also?
     
  8. tom_mai78101

    tom_mai78101 The Helper Connoisseur / Ex-MineCraft Host Staff Member

    Ratings:
    +984 / 4 / -1
    Try 7zip File Manager (7zFM) included with 7z installer.
     
  9. PooBucket

    PooBucket New Member

    Ratings:
    +12 / 0 / -0
    This looks like a great tool, but for some reason I can't open it? Am I doing something wrong? Whenever I double click it, nothing appears and only this faint sound (when you make an error) is heard when I click it :banghead:.
     
  10. PooBucket

    PooBucket New Member

    Ratings:
    +12 / 0 / -0
    Nvm it works, after I downloaded that library file from Knight770 TY SO MUCH! <3
     
  11. DeathWing

    DeathWing New Member

    Ratings:
    +3 / 0 / -0
    About source code...
    ... I heard that www.sourceforge.net gives FREE web hosting space for ppl that decide to make their source code "Open Source" :p for ya to know.
     
  12. Dameon

    Dameon "All the power in the world resides in the eyes"

    Ratings:
    +127 / 0 / -0
    I found a problim, the leak checker says that when you chose all unit's in playable map area it creates a leak, however all units and playable map area dont leak. Just thought I would let you know.
     
  13. WarToast

    WarToast Active Member

    Ratings:
    +3 / 0 / -0
    How do you make that work with Vista 64bit? I don't really have a clue about these things, so all I can do is to follow a tutorial like the one on the site. I tried placing the file in my System32 folder and then doing as it says on the site.

    Code:
    The module "\windows\system32\COMCTL32.OCX" failed to load.
    Make sure the binary is stored at the specific path or debug it to check for problems with the binary or dependant .DDL files.
    
    The specified module could not be found.
    Btw, I also have a folder called SysWOW64, should I do at that path?
     
  14. Lanboy

    Lanboy New Member

    Ratings:
    +22 / 0 / -0
    Thanks for this.

    I actually remember quite a while ago you made a patch and said that it was the final version and you'd never update it again :p

    Was sad news. Thanks for the patch. :D
     
  15. nemesispoi

    nemesispoi New Member

    Ratings:
    +5 / 0 / -0
    will this work on windows millenium?
     
  16. thewreck

    thewreck Guest

    Ratings:
    +0 / 0 / -0
    New Leak

    Hi. There is a leak this does not detect. Its incredibly simple, and I have no fix for it. Its not likely to affect most maps i guess, but in my map it has turned out to be crucial.


    TRIGGER:
    Code:
    ohNoes
        Events
            Unit - A unit Is issued an order targeting an object
        Conditions
        Actions
    this is the JASS equivalent:
    Code:
    function Trig_ohNoes_Actions takes nothing returns nothing
    endfunction
    
    //===========================================================================
    function InitTrig_ohNoes takes nothing returns nothing
        set gg_trg_ohNoes = CreateTrigger(  )
        call TriggerRegisterAnyUnitEventBJ( gg_trg_ohNoes, EVENT_PLAYER_UNIT_ISSUED_TARGET_ORDER )
        call TriggerAddAction( gg_trg_ohNoes, function Trig_ohNoes_Actions )
    endfunction
    
    This trigger, without any actions of conditions what so ever leaks about 0.25-0.5 kb of memory each time it is fired. The best way to test it is by creating a trigger which orders a unit to do something a couple of thousand times by using a (for example):

    Code:
    For each (Integer A) from 1 to 3000, do (Actions)
        Loop - Actions
            Unit - Order Footman 0002 <gen> to Right-Click Footman 0000 <gen>
    
    In my map, i use squads of units that are controlled by squad flags, thus when moving the flag, up to 20 units are ordered by triggers, thus when you have 10 flags selected, there is potentially 200 orders each time. Imagine 8 players doing this over the course of a game of an hour of say, 40 order actions per minute! Thats almost 1000 mb of memory! gah!

    Without this leaking trigger, this test action does not leak a single KB.

    Anyway, i have been reading through a number of leak tutorials, but so far have never read anything about this. Anyone knows what to do?
     
  17. tom_mai78101

    tom_mai78101 The Helper Connoisseur / Ex-MineCraft Host Staff Member

    Ratings:
    +984 / 4 / -1
    Why don't you try it and see if it can? :thup:
     
  18. nemesispoi

    nemesispoi New Member

    Ratings:
    +5 / 0 / -0
    im confused i paste the code into it and it finishes without checking anything even though i know theres leaks i just wnat to check and see if the program works which obvioulsy it doesnt work for me:banghead::banghead:
     
  19. Liope

    Liope Guest

    Ratings:
    +0 / 0 / -0
    This tool is so neat.. it suggested way to fix all the leaks and i had and it was easy to understand, really like this :p +rep for you
     

Share This Page