Patch Problem, Worser than Ever. Need full attention please

Discussion in 'Blizzard Games Help' started by Ryuu, Jul 4, 2008.

  1. Ryuu

    Ryuu I am back with Chocolate (:

    Ratings:
    +64 / 0 / -0
    I really hope this is not to the point of no return.

    Go ahead and read the spoilers if you want to.

    Okay this is the list of events that happened during the last few hours.

    Firstly, with high hopes of me testing my new map, I headed into Frozen Throne and clicked on Battle.net, downloaded the update successfully (still with high hopes), restarted Frozen Throne and they said that the checksum of worldedit.exe has failed.

    Error log:
    Code:
    Blizzard BNUpdate v2.130 compiled on Jun 24 2008
    Log created at  2:49 pm on 07/04/2008
    
    This patch upgrades Warcraft III The Frozen Throne from the previous version.
    
    ERROR: unable to apply patch to file 'c:\program files\warcraft iii (2)\warcraft iii\worldedit.exe'
    
    RESULT: Patch failed
    Secondly, (my hopes are drowned abit, but I haven't gave up yet), I created a new folder 'Warcraft III'. As you can see from the error log above, it is Warcraft III (2). So I replaced all of the Warcraft III (2) files with Warcraft III. I tested it again, and they gave me another error.
    Code:
    Blizzard BNUpdate v2.130 compiled on Jun 24 2008
    Log created at  3:43 pm on 07/04/2008
    
    This patch upgrades Warcraft III The Frozen Throne from the previous version.
    
    ERROR: unable to open source archive 'C:\Program Files\Warcraft III (2)\Warcraft III\war3x.mpq'
    
    RESULT: Patch failed
    I realised I was missing that file, so I added it in, and the first error appeared:
    Code:
    Blizzard BNUpdate v2.130 compiled on Jun 24 2008
    Log created at  4:14 pm on 07/04/2008
    
    This patch upgrades Warcraft III The Frozen Throne from the previous version.
    
    ERROR: unable to apply patch to file 'c:\program files\warcraft iii\worldedit.exe'
    
    RESULT: Patch failed
    (It was the checksum problem)

    So I manually installed the patch from 1.21b to 1.22a from Softpedia and then it gave me yet another error.

    Error log:
    Code:
    Blizzard BNUpdate v2.130 compiled on Jun 24 2008
    Log created at  7:51 pm on 07/04/2008
    
    This patch upgrades Warcraft III The Frozen Throne from the previous version.
    
    ERROR: unable to apply patch to file 'C:\Program Files\Warcraft III\game.dll'
    
    RESULT: Patch failed
    So by then I was obviously irritated. But enough talk, let's get straight to the point.

    Error is 'game.dll' wasn't found
    I tried downloading my game.dll from various websites. Then I tried again, and it gave me an error after the 'Initiating connection to Battle.net' dialog: it says that My game version is not validated and that it can be fixed by restarting Battle.net or downloading the patch manually.

    After restarting Battle.net a few times, I decided to take on the second option.

    So then I realised my version was 1.21a, not 1.21b. So I got the patch from 1.21a to 1.21b from Softpedia and I tried that, but came out another error.

    Error log:
    Code:
    Blizzard BNUpdate v2.129 compiled on Nov  2 2006
    Log created at  8:09 pm on 07/04/2008
    
    This patch upgrades Warcraft III The Frozen Throne from the previous version.
    
    ERROR: unable to apply patch to file 'UI\SoundInfo\DialogSounds.slk'
    
    RESULT: Patch failed
    It says that this file does not match the checksum.

    So can you please help me, I really need help, urgent help. REP GIVEN.

    EDIT: And please don't ask me to reinstall TFT or RoC, my disk drive has corrupted and I don't intend to use money to repair it, unless there is no other choice.
     
  2. The Helper

    The Helper Administrator Staff Member

    Ratings:
    +1,210 / 1 / -1
    You need to either reinstall from CD or download a proper installation. All the errors you are getting are because you have downloaded a hacked version of Warcraft 3 which does not have all the files and they are not properly installed.

    The latest patch takes away the requirement of having the CD in the CD drive so just install the game from ANY CD and upgrade from there. That will eliminate the problems.

    Even though Blizzard opened up there games so you don't need CDs in the drive the run we still do not support downloaded or hacked versions of the game. You fall into this category so if you want us to help you need to install the game correctly and judging by what you have posted here you are probably going to have to do that from a CD.
     
  3. Ryuu

    Ryuu I am back with Chocolate (:

    Ratings:
    +64 / 0 / -0
    Hacked version? But I installed TFT from Warcraft III Battle Chest! Or is it because I have a Warcraft III (2) folder instead of Warcraft III? And inside this Warcraft III (2) folder I have another Warcraft III folder.

    So its basically like this (this happened in 2006):
    Installed Warcraft III (inside Warcraft III folder) > I forgotten what happened but > Installed Warcraft III again (inside Warcraft III (2) folder, Warcraft III folder became inside of Warcraft III (2) folder)

    > The latest patch takes away the requirement of having the CD in the CD drive so just install the game from ANY CD and upgrade from there. That will eliminate the problems.

    That patch? Wait, I updated that already, now the patch is the one on 1st July, not the one in May!

    And I can't install the game again because:
    ________________________________________________________________________

    I am now trying to shift all files back to Warcraft III (2) folder.

    EDIT: I am happier than I should be! Though, still sad.

    I shifted all my files into the Warcraft III (2) folder and tried going onto Battle.net again, same problem (game version not validated), then I tried using the 1.21b to 1.22a manual patch and they said that game.dll was found, but wrong checksum!

    And from what I learnt about checksums, this can be fixed by having the ORIGINAL file, right? Can anyone kindly send me the original game.dll? :p
     

Share This Page