Problem with sound

Discussion in 'Starcraft 2 (SC2) Editor Help' started by MissKerrigan, Sep 18, 2012.

  1. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    Hello,

    Can somebody please tell me why all sounds disappears when zooming out the camera more??

    MissKerrigan
     
  2. Siretu

    Siretu Starcraft 2 Editor Moderator Staff Member

    Ratings:
    +295 / 0 / -0
    You might've noticed that if you move the camera away from the battle, you hear less of it. So if you're playing a melee game and you're home in your base macroing, you wont hear the battle going on at the other side of the map.

    Some sounds are 3d sounds which measure the distance between the sound origin and camera to determine how loud to play them for each player. I think this includes the camera zoom level(so your camera is higher up, so your sounds become lower and lower until they disappear)
     
    • Like Like x 2
  3. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    well it's all about a range actor which works only if I zoom-out the camera about -3

    ok, how do I program the sounds to be always the same volume on every level I zoom?

    (I don't mean zoom in the game, but already in the 'camera' editor)
     
  4. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    so how do I make the sound always hearable? even when I zoom-out the camera?
     
  5. Dan

    Dan The New Helper.Net gives me great Anxiety... o.O;;

    Ratings:
    +160 / 1 / -0
    don't play 3d sounds.
     
  6. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    I am not playing any sound... it are automatically sounds which appear at a battle, how can I change this sounds into I hear them?
     
  7. X-maul

    X-maul AKA: Demtrod

    Ratings:
    +200 / 0 / -0
    You ARE playing sounds. The sounds you are playing are determined in the actors used in the game.
     
  8. Siretu

    Siretu Starcraft 2 Editor Moderator Staff Member

    Ratings:
    +295 / 0 / -0
    You could go through all the sounds and increase the volume. It'll be a ton of work though. Maybe you can increase the volume of stuff with triggers, I don't know.
     
  9. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    ahh think I get it,

    so for example, if the weapon of the marine must be hearable at every height, I must go to the 'Marine_Attack' sound?

    But what exactly do I have to program here? there are about 100 settings in a sound
     
  10. Dave312

    Dave312 Censored for your safe viewing

    Ratings:
    +269 / 0 / -0
    Changing the volume won't actually work because you can't set the gain to anything more than 0. Setting the gain to a negative number means the sound is played at a lower volume, but 0 means it is set to its maximum volume. What you will find is the gain for most sounds is already set to 0, so you can't make it any louder.

    What you need to do is change the Sound Mode property (it needs to be set for every asset connected to the sound object). There are 3 Sound Modes. I think the one you will want is 3D Head Relative. I think this will still make the sound be played as a 3D sound but it will ignore the height of the camera. If this doesn't work. Then you will need to set it to 2D

    Like Siretu said, this will be a lot of work to change.
     
  11. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    Ok how do I make a sound 2d?

    It's no problem that it will cost time
    I'm working 20/30 hours on a map anyway so 1 more hour can't hurt
     
  12. Dave312

    Dave312 Censored for your safe viewing

    Ratings:
    +269 / 0 / -0
    Select the sound object you want to modify and open up the Sound: Assets +. Select each asset in the list and change the Mode property to either 3D Head Relative or 2D
     
  13. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    thx Dave
     
  14. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    It's working, I hear the sound even when I zoom-out the camera

    But now when I go to the right-top of the map I can hear sounds in the left-corner


    It's a great editor, but I really CAN'T believe this little issue
     
  15. Dave312

    Dave312 Censored for your safe viewing

    Ratings:
    +269 / 0 / -0
    Did you set it to 3D Head Relative or 2D?
     
  16. MissKerrigan

    MissKerrigan Active Member

    Ratings:
    +23 / 0 / -0
    3D World Relative: I am NOT hearing the sound when zooming-out the camera

    3D Head Relative: I am NOT hearing any sound at all

    2D: I hear the sound now all over the map at the same volume, even when zooming out-camera about 100


    I tried to modify the heigth of a point by setting it to about 30/40 and creating a sound at that point, but even this wasn't working

    But to be honest I found something about the range actor now!! I don't need to zoom-out the camera now and this means I don't need sounds at greater height, it's ok now
     

Share This Page