repetitive unit spawn disables Upgrades (after beeing disabled)

Discussion in 'World Editor Help' started by LordTalbot, Oct 24, 2016.

  1. LordTalbot

    LordTalbot New Member

    Ratings:
    +0 / 0 / -0
    Hello all,
    I'm triggering with the GUI and I have the following problem:
    I have a trigger that, every time that a unit has been trained, orders the training building to train that unit type again.
    The trigger works perfecty fine, but when I cancel the unit production the building can't be upgraded.
    The critical trigger is the second one and right now its not "issue order to train a unit of type of trained unit, but that leads to the same problem ( I just tried a lot of things meanwhile)
    [​IMG]
    I have disabled pretty much all other triggers that could in any way interfere with this trigger, but the problem only occurs when I turn on this precise trigger.

    The problem only occurs after producing the first unit in a building (so the trigger ran once for that unit/building).

    I could make an ugly workarround but I don't want to waste performance. Do you have any idea why this happens or how to solve this? Maybe something is broken in the GUI function or I'm blind :(

    thanks in advance
     
  2. Accname

    Accname 2D-Graphics enthusiast

    Ratings:
    +1,549 / 4 / -4
    It would be nice to get some more details. You said
    but what does that mean? Why can you not upgrade your building? Does the button not appear?
     
  3. LordTalbot

    LordTalbot New Member

    Ratings:
    +0 / 0 / -0
    sorry that I missed that, the button is greyed out but it doesn't show any reason. it is the same as when I have units in production
     
  4. LordTalbot

    LordTalbot New Member

    Ratings:
    +0 / 0 / -0
    so, when I don't run that trigger upgrading works normal (also when the unit produced units ordered by the first trigger shown above [after it's been constructed] upgrading still works normal).

    I uploaded a screenshot of the looks just in case, but I don't see any information :/ it is the same as if the building is currently producing units. the text is only the tooltip and advanced tooltip beeing shown.
    [​IMG]
     
    Last edited: Oct 24, 2016
  5. Accname

    Accname 2D-Graphics enthusiast

    Ratings:
    +1,549 / 4 / -4
    I have never seen anything like that before. Could you upload the map for me to have a closer look?
     
  6. LordTalbot

    LordTalbot New Member

    Ratings:
    +0 / 0 / -0
  7. Accname

    Accname 2D-Graphics enthusiast

    Ratings:
    +1,549 / 4 / -4
    Played around with it but as far as I can see there is not much you can do about it. I couldnt make it work either. If I had to guess I'd say it is a bug within the wc3 engine of which there are plenty. What you can do is replace the unit with a new unit of the same type which will fix it temporarily though.
    Trigger:
    • Unit - Replace UNIT with a (Unit-type of UNIT) using The old unit's life and mana
     
  8. LordTalbot

    LordTalbot New Member

    Ratings:
    +0 / 0 / -0
    yeah thank you lol... I can gladly say that I am quite experienced with the gui and i know how to replace a unit xD I had the replacing on my mind too, but i wanna do some more stuff and it doesnt seem optimal to me. I will make a wordarround of this kind though :p

    but overall, this means you couldnt solve this with a direct jass method too? or did you try it only with the GUI as well?
     
  9. jonas

    jonas Member

    Ratings:
    +41 / 4 / -0
    There was a Blizz Map (the one with air planes) that uses a similar concept, but I'm not sure whether they have upgrades. You should have a look.
     
  10. LordTalbot

    LordTalbot New Member

    Ratings:
    +0 / 0 / -0
    i just had a look at bombercommand and it works very differently, as the units are not actually trained by buildings but instead are triggered.
     

Share This Page