Unit Portrait is gone? I need it back.

Discussion in 'World Editor Help' started by 3ICE, Aug 3, 2007.

  1. 3ICE

    3ICE Cool Member

    Ratings:
    +3 / 0 / -0
    (Sorry for the word portrait but i don't know how else i could call the icon near the unit stats)
    I don't know what caused my portraits to disappear like the ones on the attached GIF.
    The first picture is a critter that has immolation.
    The second one is just a Demon Hunter.
    Now, my map is heavily customized and i looked over everything but couldn't find the reason why my portraits are gone.
    I tested an other map and portraits appeared, so the problem is with my map only.
    None of my units (in my map) have portraits all have a black empty window instead.
    (Hero portrait in the top left corner works)
    I don't know what else to say so; Please Help.
    Thank you for your time.

    Image: (GIF, contains two pictures describing the problem i need help with)
     

    Attached Files:

  2. Wolves

    Wolves Guest

    Ratings:
    +0 / 0 / -0
    mabye try useing a different model, usually its the model bug
     
  3. 3ICE

    3ICE Cool Member

    Ratings:
    +3 / 0 / -0
    i used the DEFAULT night elf demon hunter model -.-
     
  4. C-Death

    C-Death I love you

    Ratings:
    +44 / 0 / -0
    When ever this happens to me, it usly means one of my models or custom things is not getting along with some of my triggers, try taking out something that doesn't 100% criticly need to be there.
     
  5. 3ICE

    3ICE Cool Member

    Ratings:
    +3 / 0 / -0
    i dont have any custom models in my game.
    when saying heavily modified i ment to say the strings in game interface. i did not touch any models.

    i have been working on my problem and did the following:
    exported all my object data into a file
    made a new map and imported every object data.
    now all my units and spells were trasported and the icon things were back so i will now do this:

    export everything (variables (omfg i have a lot) units spels triggers and terrain) then import them to a new map.
    BUT! exporting strings doesnt work perfectly (last time i tried this happened: "force names become player names and all the game interface strings are messed up")
    ... i will keep trying

    okay i have exported the following files:
    war3map .w3o .w3u .wct .wtg .wts and .j

    i still miss these files:
    war3map .doo .mmp .shd .w3a .w3c .s3e .w3i .w3r .w3t .wmp
    How can i export using the world editor? or which one needs to be exported and which one doesn't?

    also, war3mapmisc.txt war3mapskin.txt and war3mapunits.doo aren't exportable but i would need them...

    any one know what those files do or wheres the export button hidden?

    i found the missing buttons they were item data doodad data and others. now i try to get the game interface exported and also gameplay constants .

    uhh while exporting the triggers i got all of them disabled due to missing units... i dont know how to export preplaced units so if anyone know please let me know.

    came accross another problem... strings cannot be imported due to a thousand IDs are missing... an error message as big as my screen came up listing the missing IDs
    i wont give up but some assistance would be welcome.
     
  6. Sooda

    Sooda Diversity enchants

    Ratings:
    +318 / 0 / -0
    > How can i export using the world editor? or which one needs to be exported and which one doesn't?

    Go to our tutorial repository and find out Tonks tutorial how to change things with MPQ Editor (Tutorial is meant for RoC users, but explanes how to edit map or browse it' s content without WorldEditor.).
    Your map could be corrupted are you using modified WorldEditor to create your maps ?

    EDIT: We got also thread where are all tutorial listed, it' s called The Index. There is Tonks tutorial also.
     
  7. 3ICE

    3ICE Cool Member

    Ratings:
    +3 / 0 / -0
    >Sooda
    i have read all tutorials on this site. i know about mpq hacking but i wanted to know if there was a legal way of exporting game interface strings using the w.e. and no, i use the normal w.e i tried weu but didnt need any of it's features. im fine with the normal w.e

    also:

    I RESET EVERY SINGLE D*M UNIT ON MY MAP ALSO REMOVED ALL TRIGGERS AND THE PORTRAITS ARE BACK. (yay!) now time to reopen my map and reset 1 by 1 looking for which one bugs the game. thx for the (nothing) help guys my problem is probably solved. if not i will post again.
    thx.

    edit just so u guys know whats up:

    i reopened my map and deleted all trigegrs. now the portraits are back.

    conclusion: a trigger killed the portraits.
    now im deleting triggers 1 by 1 and testing after each trigger deleted. to see which one is the murderer or portraits. i will edit this post again and tell you which trigger is such an <insert bad word> to bug my game.

    that was pretty easy: the very first trigger called IN (for initialization) did it. now im deleting functions 1 by 1 etc etc lets see which action is the <bad word>...

    GOD SHALL STRIKE ON:

    Cinematic - Turn on letterbox mode (hide interface) for (All players): fade out over 0.00 seconds

    because after removing that action suddenly all bugs were gone.
    note: the event was Time - Elapsed game time is 1.00 seconds
     

Share This Page