USB Ports don't work

Wark

Animal
I'm having some trouble with my USB ports and I was hoping one of you could help me out.

I'm running WinXp pre-SP1
Have a Socket A Mainboard Model K7S5A Pro

I was trying to install a FireWire driver for my PCI FireWire card, and I downloaded a USB driver instead. I installed it and... it messed up my USB ports.

I've tried to delete the USB drivers from "Device Manager" and then go into my BIOS, disable USB, reboot to windows, go back to BIOS, enable USB, and reboot yet again to windows. It worked fine, and Windows had installed USB drivers, but alas, when I plug in my mouse, it won't detect it, or anything.

My mouse's light still works, so I'm assuming it's something to do with the drivers.

Any help would be greatly appreciated.

PS: Perhaps I should start posting here more often again, and maybe even go back to WC3...
 

SFilip

Gone but not forgotten
Well presumably you installed the wrong driver which Windows now sees as the better option.
Try going to Device Manager, right click on the USB driver and click on Update Driver. Make sure you pick to select it from a list and then find your old driver there...if you don't remember which one it was then I guess you'll have to try them all (keep the mouse plugged in and notice when Windows detects it).
 

Wark

Animal
Thanks for the reply,

My USB drivers are as follows:

SiS 7001 PCI to USB Open Host Controller
SiA 7001 PCI to USB Open Host Controller
USB Root Hub
USB Root HUb

I only have 4 usb ports.

I tried to update the drivers as you said, but there were no options to update to for the two "USB Root Hub" drivers. Although, there was 1 other for the "SiS 7001" driver called "Standard HCD USB Open Host Controller", so I updated to that.

Still no luck, as it did not detect my mouse, nor anything else
 

SFilip

Gone but not forgotten
Hm lets try a different approach...
Which motherboard are you using?
Go to its manufacturer's site and see if you can find something there. Look for either an USB driver or perhaps a chipset utility.
 

Wark

Animal
The manual just says "Socket A Mainboard" and it gives the model number 'K7S5A PRO'.

I have a cd that it came with it, and it has two sets of USB drivers: 'SiS' and 'VIA'. I tried to install
both, but niether seemed to work either...

EDIT: Actually, I think the manufacturer might be 'SiS' since there are several other drivers named "SiS x y z"
 

SFilip

Gone but not forgotten
Well after installing the drivers you will probably have to go through that update driver deal again, this time picking either that VIA or SiS.

Edit: Yeah, just checked, your card has the SiS chipset so you should pick the SiS driver.
 

Wark

Animal
Hmm.

Well I installed the 'SiS' drivers from my motherboard CD, and I gave me an error right at the end of installation, titled something like "ErrorUSBUpgradingPlugandPlay" after the error message it said "Install finished successfully", yet it still didn't fix the problem.

I downloaded another SiS driver from the internet, but I wasn't sure which one it was (the SiS website doesn't have USB drivers). After installing it, I got the exact same error.

Not sure what's going on, but all the driver I've tried to install fail to work as of yet.
 

Wark

Animal
As a follow-up, I decided to buy a USB 2.0 card, with a VIA chipset. And I also reformatted my computer and installed SP1. Still no luck. The USB ports provide power, but Windows doesn't detect anything. Windows also doesn't even detect the USB PCI card I installed.

Now I'm starting to think a USB port also shorted out my Logitech Mx518 mouse, as it's not getting power from either ports, and my backup mouse is...

At this point I'm probably going to bring it in to a PC repair shop. I'm pretty surprised installing a wrong driver can do this...
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • tom_mai78101 tom_mai78101:
    Would like to get some annual forum statistics report.
  • The Helper The Helper:
    there are stats in the xenforo forum admin section and we have matomo stats we started collecting beginning of the year so we will not have annual on that until next year
  • The Helper The Helper:
    I thought you had keys to the bathroom Tom? Ghan does Tom have access to the stats thread in the bathroom
  • The Helper The Helper:
    since I started jacking with the bots on the site we doubled our page views on the site in a week lol
  • The Helper The Helper:
    I have been having lots of fun
  • The Helper The Helper:
    we have had like 6000 views of the American Airlines economy class thread in the last week
  • The Helper The Helper:
    I ought to stick a travel affiliate link or something on that page to try and monetize that they are just going there and leaving it might even be bots I am not sure
  • The Helper The Helper:
    I just got into it with the Atari VCS Facebook Moderator I started trolling him and almost got banned
  • The Helper The Helper:
    They deleted one of my posts one time so I was trolling him on a help post I put up because I am evil I guess and bored and the guy handled it well I loved his attitude Atari has a good social media presence even if they do not have many games.
  • The Helper The Helper:
    The French Atari they call them even though they are like totally based in America they just have French Money coming in. Gotta love it
  • Ghan Ghan:
    Microsoft buying Activision Blizzard holy crap!
  • The Helper The Helper:
    I know right holy cow
  • Accname Accname:
    Thats not going to save it.
  • The Helper The Helper:
    It might
  • The Helper The Helper:
    They are going to use alot of that IP in the Metaverse
  • The Helper The Helper:
    I found a new section of the stats that is freaking interesting!
  • The Helper The Helper:
    oh yeah this is what I was looking for good job matomo! These are some sweet stats I am learning the interface on it too!
  • The Helper The Helper:
    If anyone ever asks later how I found out about it was watching the site bots but not watching what they were doing but asking myself why they were here?
  • The Helper The Helper:
    there must be a reason and ok that is it
  • The Helper The Helper:
    the past and the future all come together into one
  • The Helper The Helper:
    the search engines are what built thehelper.net the search engines will make it big again maybe
  • The Helper The Helper:
    the real question is are 5 million links better than 60 real good links?
  • The Helper The Helper:
    the answer is 60 lol
  • The Helper The Helper:
    unless you put 100k links on it lol then you get something

    Staff online

    Members online

    Affiliates

    Hive Workshop NUON Dome
    Top