How to build refineries/extractors/assimilators on top of each other?

Discussion in 'Starcraft 2 (SC2) Editor Help' started by Lachimus, Sep 29, 2017.

  1. Lachimus

    Lachimus New Member

    Ratings:
    +0 / 0 / -0
    I'm trying to re-create a "fastest possible" from SC1 but I'm having trouble getting the gas guzzlers built on top of each other.

    I have placed a couple lines of 4 vespene geysers on both sides of the start location, unchecked the "placement check layer" to no build in wizard view for ref/ext/ass but I still can't get my little workers to build on the available geysers when I test....

    I also have no idea how to upload pics or, like, lists of what I've done, either... so... yeah :confused::confused::confused:

    Any clues for this super n00b..???

    Cheers :)
     
  2. Lachimus

    Lachimus New Member

    Ratings:
    +0 / 0 / -0
    bump?
     
  3. jesse

    jesse Member

    Ratings:
    +0 / 0 / -0
    please go into more detail. are mean like you are just trying to build a refinery on a geyser like normal and it doesn't work?

    press the print screen button on your keyboard, open paint, ctrl+v, save it uplaod
     
  4. Lachimus

    Lachimus New Member

    Ratings:
    +0 / 0 / -0
    Hey, Jesse.

    So I'm trying to stack gasses as close as possible to the CC. What I can't seem to do is then build the refineries if the gasses are on top of each other as in the second picture.

    Cheers!
     

    Attached Files:

  5. jesse

    jesse Member

    Ratings:
    +0 / 0 / -0
    hey man, i just tried to replicate what you did, i did 2 things and i could build on them in game,

    firstly i opened the footprint and removed all the yellow blockers fom the footprint template for the refinery. then i removed all of the collide under movement for refinery. "structure" "ground" etc.

    This might not provide the solution you desire as the refinery might have no collision with other units but i beleive this is what you need to use.

    my understanding is that because you have the geysers overlapped the refinery is happy to build on the first gyser, but then it is "colliding" with the other ones, so you need to have the refinery and the geyser not share a common collison flag.

    I suggest testing a few differnt variations and see if you can get it working. hope this helps
    upload_2017-12-16_1-48-11.png
     
  6. jesse

    jesse Member

    Ratings:
    +0 / 0 / -0
    try the collision fix first before you play with the footprints
     
  7. Lachimus

    Lachimus New Member

    Ratings:
    +0 / 0 / -0
    Thanks!!!
     
  8. Lachimus

    Lachimus New Member

    Ratings:
    +0 / 0 / -0
    :/ I tried to do this, and tried some other footprint changing and managed to mess it up completely :D my cc wont start in the middle of the mineral/vespine patches... and then I wasn't able to place any more vespine in the editor.. and yeah. I just quit and didn't save ^_^'
     
  9. jesse

    jesse Member

    Ratings:
    +0 / 0 / -0
    yeah its trial and error
    change something, then test, try something else test
    i have like a different save for each change, literally hundreds of saves
     

    Attached Files:

  10. Lachimus

    Lachimus New Member

    Ratings:
    +0 / 0 / -0
    lol X'((
     

Share This Page