Game crashes after battlefield logo appears

Discussion in 'Battlefield Support' started by Unregistered, Mar 14, 2003.

  1. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    I need some help people..i have installed the full game from a legal copy, but it will not load,, the game crashes very shortly after the bf1942 logo appears,,,,graphics card is Geforce 4 MMX440 i have been told this can cuase problems? Its absoloutly pissing me off seeing as i just paid the $90 for the game....is there anything that can be done to stop this problem...,,
    oh yeah another thing as it crashes the windows error sound beeps and a window.presumably a error message appears and disappears before one can actually read or see what it is...then i am returned to the desktop....PLEASE PLEASE help
     
  2. Wargasm

    Wargasm Administrator Staff Member

    Ratings:
    +47 / 0 / -0
    get the latest vidcard drivers for that video card and the last patches problem shouldbe gone then
     
  3. json9999

    json9999 Guest

    Ratings:
    +0 / 0 / -0
    battlefield 1942 crashes to desktop

    I am currently on a Athelon 1.8+ system with 511megs ram. A Gainward GeForce 4Ti 64mb graphics card. I went through all of the fixes patches updating all my devices and I am still crashing to my desktop when I try and start the game. Please help!!!
     
  4. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    Same problem. Gainward GF4 Ti4200 128mb, Athalon XP 2200+, gigabyte mobo/w Via chipset

    I've updated everything I could think of, tried the wordpad fix, shut down all the background programs, disabled antivirus software, tried starting from both CD's, and all of that. Just about the only thing I haven't done is gotten XP service pack 3 from microsoft. Still crashes. This is driving me out of my mind. Does anyone have a surefire fix?
     
  5. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    crashes at startup

    the bf1942 logo comes up when I open the game then the screen goes blank, and then a small box appears for just a second then disappears, and thats it. I already know that the problem is that my video card isnt good enough. and I keep hearing about needing to download some kind of patch to update the video card or just buying a new one. my problem is that I cant find out what video card I have. I searched in my computer and all I came up with is quicktime and SVGA, but I dont even know if that was the video card or not. CAN ANYONE TELL ME HOW TO FIND MY VIDEO CARD? OR SOME OTHER BETTER WAY TO FIX THE PROBLEM?


    If I seem stupid keep in mind I am only 14 by the way.
     
  6. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    C:\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings

    go here open VideoDefault.con

    Change renderer.allowAllRefreshRates 0
    to
    renderer.allowAllRefreshRates 1
     
  7. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    Hmm I have the same problem .. And that thing dont fix it ..! What to do?
     
  8. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    Simple, open the video default file with notepad (make sure tro uncheck always open these programs with this file type) then change it. It worked for me. :):):):):):):)
     
  9. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    yah yah yah, just stopping by

    "C:\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings
    go here open VideoDefault.con
    Change renderer.allowAllRefreshRates 0
    to
    renderer.allowAllRefreshRates 1"

    is EXACTLY what I needed. Thank you SO much!

    Everyone else, go find the Via chipset patch for 1942. Heh, I have an Intel so I don't have a Via chipset. Bleh.
     
  10. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    Thankyou Thankyou Thankyou Thankyou Thankyou Thankyou Thankyou!

    You can have my babies, this fix works like a charm.

    --Scythe--
     
  11. Unregistered

    Unregistered Guest

    Ratings:
    +0 / 0 / -0
    I dont have a "mods" folder...but I do have a

    C:\Program Files\EA GAMES\Battlefield 1942\Settings folder...

    and in there is videodefault.con but the renderer.allowAllRefreshRates line of text was not in there... tryed adding it and making it 1 and it still didn't work :(
     
  12. bandora

    bandora Guest

    Ratings:
    +0 / 0 / -0
    i only have 3 files in the the mods file what is sposed 2 be in there
     
  13. sr2owens

    sr2owens Guest

    Ratings:
    +0 / 0 / -0
    In a un-corrupted install of BF1942 , you should have a mod folder.

    Maybe you should un-install the game and re-install it.

    Anyway, thanks to the person who mentioned the VIA chipset patch.

    Steve O
     
  14. PlzHelp

    PlzHelp Guest

    Ratings:
    +0 / 0 / -0
    Well,
    If i play BF 1942 1.0 it works fine, but when in play 6.0 it doesn't work anymore,
    And it crashes to the desktop.
    I have a Via chipset so could that be it?
     
  15. 787

    787 Guest

    Ratings:
    +0 / 0 / -0
    patch damn it

    when i install version 1.6 for bf1942 my game says insert cd rom.so i simply copy and paste crack of bf1942.but then when i run game thenit crashes back to desktop.
     
  16. Gilthos

    Gilthos New Member

    Ratings:
    +0 / 0 / -0
    Here it is, a decade later, and the game still does the same thing. I recently installed the game onto my computer with the expansions and it does the same thing (although some on the web say it runs in NT mode, the computer thinks there are no discs in the drive when I try that mode). I tried to run it in every compatibility mode, as administrator, the AllowRefreshRates is already at 1. I have the latest patch. Origin/EA Tech Support is totally clueless. They could not grasp that I own the actual discs and didn't download it or that with the discs, you do not use online severs but can host games on your own computer.

    Any ideas?
     

Share This Page