Problem with Builders...

Anything.

New Member
Reaction score
69
Resolved.

So the story goes: Once upon a time, I copied and pasted my Peasant unit and then made a Mason unit, edited the stuff it builds, then place it in the map. Well, it just so happens that I press the Test Map button, then try to build something with it.

WCIII closes.

Now, whenever I try to put any of the buildings which that unit has into the Structures Built area of any unit, that unit no longer has the ability to build anything, and once the Build button is clicked, WCIII shuts down.

The story ends with me not being able to build any of my Custom Buildings.

Does anyone know what the problem is?
Edit - And if I didn't make this clear, I want to know the solution, not the problem. I know what the problem is.

THESE DO NOT CAUSE THE PROBLEM, SO DON'T SUGGEST THEM:
  • Unit builds something outside of its own race. No, my Peasant unit could build Orc units prior to this bug.
  • Unit has Wisp Gather Gold ability. NO.
  • Unit doesn't have 'Build' spell. It has it; and it's not an issue of building the unit, it's an issue of even selecting it and placing it on the map.
  • A new building was added to the Structures Built area and it created a bug. No, since one of my buildings which was previously buildable now closes WCIII if it's in the Structures Built area.
  • One of the older buildings was changed and now is bugged. No, since I didn't change anything.
  • Remake all of the buildings. Funny, YOU can do that for me.
  • Something is wrong with the builder, make a new one! No, just no. It doesn't work, it's something about the stuff it builds.
  • WE just hates you. Well, obviously.
 
I don't think that custom models would cause WC3 to crash. Have you tried copying and pasting all the custom data into a blank map and testing it?
 
What about custom models. Did you add any?

To clarify; whenever I select the unit, I am able to move it around perfectly fine; however, when I press the build button, my WCIII closes without any notice. There are no custom icons within the build menu, and all buildings it used to have still function, but can't be placed within any build menu at all, or else the "close when press Build" thing happens again.

I don't think that custom models would cause WC3 to crash. Have you tried copying and pasting all the custom data into a blank map and testing it?

No, not yet, and I can't right now since WE is on my other computer.
 
Do you have any spellbooks that contain itself or other spell books infinately?
 
Do you have any spellbooks that contain itself or other spell books infinately?

Well, that has nothing to do with anything; but the answer is no.

It's just a normal builder with some buildings listed under its build-list.
 
Well, that has nothing to do with anything; but the answer is no.

Actually, that has everything to do with this issue. Because the problem you are describing sounds like circular equivilency. This issue is usually caused by one unit being equivalent to another one, and that other one being equivalent to the first one. Solution: Remove one of the equivalences.
Obviously, the problem is with something that the map tries to access when processing your build menu. If you are completely positive that you haven't added anything, and haven't changed anything (obviously not the case since it worked before and now doesn't work), then there is probably nothing more we, or anyone else can do for you. I would think long and carefully about any dependencies you might have anywhere on your map and double check for recursions.
 
Let me Ask something first...

Your Builder Build a Structure, What Structure is it?
What are the structures it has?
And WC3 Closes itself with no Error right?
And Terrabull does explain why it happends. So Check up to see if its because of this.
 
The only thing I've done so far is make two new buildings, which, incidentally, have not been added to either builder, and made a new builder. To the new builder, I added some buildings, and now, I am unable to add any Custom Buildings to any builder unit or else WCIII closes when I press Build.

I have long deleted the second builder.

The only dependency I have is that Town Center II is equal to Town Center I, but the builders can't even make that unit.

Builder #1 - Peasant
-- Mill
-- Farm
-- Farm (2)
-- House (1)
-- Forge
-- Barricade
-- Outpost

Builder #2 - Mason
-- Barracks
-- Range
-- House (2)
-- Forge

At the current state, Builder #1 can't have ANY of its former Buildings in its Build-list, except Farm and Farm (2); otherwise WCIII will shut down when Build is selected. Builder #2 can't build any of its buildings.

And yes, there is no error whatsoever.
 
If you dont mind upload your map?
Because I do face the same problems when I put buildings Upgrade to each other, like an infinite Loop.
 
I can't access the map at the moment, but I will get it up as soon as possible.

I don't think it has to do with the units upgrading into each other as I can't even build them anymore, but I can place them in WE before testing the map and they function fine.

It could be a problem that all the units were copied & pasted from the Farm unit, but again, it worked fine before I added a second builder.
 
Hmm....

Its either
1 - 2 Structures can upgrade themself to the other one.
Like..
X - Upgrade - Y
Y - Upgrade - X

Or 2 - 2 Structures Having Dependency on each other

Thats the sources of this problem when im doing my Sandbox Map.

Try to seek out as you might have accidently added this.
And Units do also get involved in this as the whole data tree is processed together.
 
#1 = No.
#2 = Maybe, but probably not since all of my buildings aren't working, which implies that all of them are somehow equal.

(I've tested the buildings individually by placing them by themselves in a Build-list)
 
It is not nessisarily the buildings that they can build that have to have this error. Any unit that is refrenced by a unit they can build might have an error that would cause War3 to crash like this.
 
It is not nessisarily the buildings that they can build that have to have this error. Any unit that is refrenced by a unit they can build might have an error that would cause War3 to crash like this.

What does this mean exactly?

If this means anything: I can place the buildings and every single Custom Unit, as well as units I've changed into WE and then test the map without any problems (meaning upgrading things, moving things, attacking, creating additional units), except with the Build error.

The original Peasant, as well as every other Builder in-game works fine, and prior to the crashing thing, my first copy of the Peasant did as well; only after making my second custom builder did I lose the ability to add Custom buildings to any builder's Build-list.
 
I've enclosed the map that is causing problems.

What I've done since the last time the map was functioning as intended:
-- Copied and Pasted Peasant (Custom Unit) and renamed new builder Mason.
-- Created Range and Barracks (Custom Buildings)
-- Added to Mason Build-list.
-- Placed Mason and Peasant both on map.
-- Tested; both closed WC3 when Build was clicked.
-- Removed Range and Barracks from Mason; still closed.
-- Deleted Mason; Peasant (custom) still closed.
-- Deleted Peasant.
-- Remade Peasant; WC3 still closed.
-- Deleted it.
-- Put Peasant (real one) onto map; could build and did not close WC3.
-- Added a custom building to the unit; could not build.
-- Repeated for each building; could not build, except for Farm and Farm (2).
-- Removed all melee buildings from it, then retested one building at a time; same results.
-- Deleted Mill unit and remade it. Added new Mill unit alone to Peasant (real); could not build.
 
What does this mean exactly?
It means that you need to look at all your units, not just the ones that the builders can make.

If this means anything: I can place the buildings and every single Custom Unit, as well as units I've changed into WE and then test the map without any problems (meaning upgrading things, moving things, attacking, creating additional units), except with the Build error.

Nope, sorry, it doesn't mean anything. This problem only effects the game when the game checks the dependencies.

The original Peasant, as well as every other Builder in-game works fine, and prior to the crashing thing, my first copy of the Peasant did as well; only after making my second custom builder did I lose the ability to add Custom buildings to any builder's Build-list.

Again, not relevant to this problem. This problem happens because the game tries to decide IF you can build something, and when it gets to the circular dependency loops infinitely. Thus, preplaced units will not have this problem, nor will normal units in the game, because they don't have any errors like this.
 
I have your problem surfaced. Remove the dependency of the Town Center on the Town Center II, thats the source of your problem as When it Upgrades, it is also treated as a Town Center by itself, there is no need to add that dependency equivalents. Try it.

= Tested it earlier on, I could build without my WC3 Closing. =
 
Code:
   upgrade
X     >>    Y
Y     >>    X

2building upgrade to each other will cause bug?
i though in green td, the 2aura tower can upgrade to each other?
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • The Helper The Helper:
    https://www.thehelper.net/pages/news/ is a link to the old news portal - i will integrate it into the interface somewhere when i figure it out
  • Ghan Ghan:
    Need to try something
  • Ghan Ghan:
    Hopefully this won't cause problems.
  • Ghan Ghan:
    Hmm
  • Ghan Ghan:
    I have converted the Headline News forum to an Article type forum. It will now show the top 20 threads with more detail of each thread.
  • Ghan Ghan:
    See how we like that.
  • The Helper The Helper:
    I do not see a way to go past the 1st page of posts on the forum though
  • The Helper The Helper:
    It is OK though for the main page to open up on the forum in the view it was before. As long as the portal has its own URL so it can be viewed that way I do want to try it as a regular forum view for a while
  • Ghan Ghan:
    Yeah I'm not sure what the deal is with the pagination.
  • Ghan Ghan:
    It SHOULD be there so I think it might just be an artifact of having an older style.
  • Ghan Ghan:
    I switched it to a "Standard" article forum. This will show the thread list like normal, but the threads themselves will have the first post set up above the rest of the "comments"
  • The Helper The Helper:
    I don't really get that article forum but I think it is because I have never really seen it used on a multi post thread
  • Ghan Ghan:
    RpNation makes more use of it right now as an example: https://www.rpnation.com/news/
  • The Helper The Helper:
  • The Helper The Helper:
    What do you think Tom?
  • tom_mai78101 tom_mai78101:
    I will have to get used to this.
  • tom_mai78101 tom_mai78101:
    The latest news feed looks good
  • The Helper The Helper:
    I would like to see it again like Ghan had it the first time with pagination though - without the pagination that view will not work but with pagination it just might...
  • The Helper The Helper:
    This drink recipe I have had more than a few times back in the day! Mind Eraser https://www.thehelper.net/threads/cocktail-mind-eraser.194720/
  • The Helper The Helper:
    Happy Thursday!
  • Ghan Ghan:
    I'm not so sure, there's still a lot of Thursday left for it to become unhappy.
    +2
  • The Helper The Helper:
    still a few hours
  • The Helper The Helper:
    Its Friday!!!!
    +1
  • Ghan Ghan:
    Thursday 7/10 would Thursday again
    +2

      The Helper Discord

      Staff online

      Members online

      Affiliates

      Hive Workshop NUON Dome World Editor Tutorials

      Network Sponsors

      Apex Steel Pipe - Buys and sells Steel Pipe.
      Top